Region-dependent connection issue

Major incident Cloud Suite Germany
05.05.2026 21:43 CEST · 9 hours, 30 minutes

Updates

Resolved

A widespread DNS failure prevented access to all .de domains last night due to a DNSSEC validation problem. The root .de zone’s digital signature (SOA record) became invalidated, causing DNS servers worldwide to reject these domains.
The root cause was a malformed cryptographic signature in DENIC’s DNS configuration.

May 6, 2026 · 00:20 CEST
Issue

We are currently observing region/provider dependent connection issues to our Cloud Abo service in Germany. We informed our cloud infrastructure provider accordingly and monitor the situation.

May 5, 2026 · 22:31 CEST

← Back